Atualizado Debian 6.0: 6.0.1 lançado

O projeto Debian tem o prazer de anunciar a primeira atualização de sua distribuição estável Debian 6.0 (codinome squeeze ). Esta atualização adiciona correções principalmente para problemas de segurança para a versão estável, junto com um ajuste de alguns problemas sérios.

Por favor, note que esta atualização não constitui uma nova versão do Debian 6.0, mas apenas atualiza alguns dos pacotes incluídos. Não há necessidade de jogar fora 6,0 CDs ou DVDs, mas apenas para atualizar através de um espelho up-to-date Debian após a instalação, para causar qualquer dos pacotes da data a ser atualizado.

Aqueles que freqüentemente instalar atualizações do security.debian.org não terão que atualizar muitos pacotes ea maioria das atualizações do security.debian.org estão incluídas nesta atualização.

Novo CD e DVD contendo imagens pacotes atualizados e meio de instalação regular acompanhado com o repositório de pacotes, respectivamente, estarão disponíveis em breve nos locais regulares.

Atualização online para esta revisão é geralmente feita apontando o aptitude (ou apt) ferramenta de pacotes (ver o sources.list (5) página do manual) para um dos muitos sistemas Debian FTP ou HTTP espelhos. Uma lista completa de espelhos está disponível em:

http://www.debian.org/mirror/list
Diversos Bugfixes

Esta atualização adiciona estável algumas correções importantes para os seguintes pacotes:

Pacote Razão
dater-apt A sintaxe correta do arquivo de configuração padrão
base-files Atualize / etc / debian_version para o lançamento ponto
cdebconf Permitir que o frontend para ser usado em uma janela de ambiente gerenciado
clamav Novo montante bugfix release
clive Adaptar para as mudanças youtube.com
cmake Reconstruir versão do autor para remover o Windows indistribuível construir sistemas de arquivos
console-setup Corrigir o suíço-alemão, búlgaro e keymaps sueca no instalador
cryptsetup Instale gancho initramfs cryptkeyctl; lukadmin: evitar condições de corrida, invocando udevadm possível resolver
dbconfig-common versão Fix bug lógica classificação em arquivos de atualização em postinst
debian-reference Consulte a espremer-updates e não volátil; URL correção para Debian Mirror Checker
debootstrap Correção – Utilização de chave privada e ar
dilúvio Fix pendurar em sair
desktop-base Fix saída plymouth em configurações dual-screen
devscripts Faça espremer o alvo padrão de backports, adicione wheezy {,-ignore} tags
eclipse Fix XSS na aplicação navegador de ajuda
exuberante-ctags Use memmove ao invés de strings strcpy na sobreposição
ganeti Não quebre as permissões de / var / lock durante a execução gnt-node add
gdm3 Manipular del {usuário, grupo} falhas graciosamente; uso grep correção; usar nomes corretos para locales UTF-8
gedit Corrigir erro importante na tradução Português do Brasil
git Fix escapar em gitweb, variável add.ignoreErrors novo
gnome-screensaver Desativar não-funcionais libnotify apoio
cliente gnumed Instale as traduções para o local correto
grub-installer Define o título do debconf para evitar a reutilização de um anterior
ia32-libs pacotes de atualização de “estável” e propôs-updates
ia32-libs-core pacotes de atualização de “estável” e propôs-updates
ia32-libs-gtk pacotes de atualização de “estável” e propôs-updates
instalação, guia de Atualização de conteúdo para espremer
katoob Fix falhar quando ajustando tooltips
kde4libs Adicionar um script para migrar kconf_update longe de velhos temas ícone KDE3
kdebase-workspace Fix KRunner aleatória, mas comuns acidentes
kernel-cunha Adicionar módulos escondeu-cereja e sdhci_pci
kfreebsd-8 DoS Fix locais pilha TCP; emular catalão meio-ponto l caracteres / L por l ASCII / L
kgb-bot Fix verificação de versão para permitir que possíveis futuras atualizações de segurança
Krusader Devidamente corrigir problemas que encerra a aplicação
libapache-mod-jk A facilidade de upgrades lenny, desativando o uso SOCK_CLOEXEC
libemail-mime-createhtml-perl Adicionar a dependência em falta no libfile-política-perl
libvirt Faça init script status de saída de destino status compatível com a LSB para auxiliar de monitoramento
linux-2.6 Várias correções
linux-kernel-di-amd64-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-armel-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-i386-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-ia64-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-mips-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-mipsel-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-powerpc-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-s390-2.6 Reconstruir contra linux-2.6 2.6.32-31
linux-kernel-di-sparc-2.6 Reconstruir contra linux-2.6 2.6.32-31
magpierss Correção de vulnerabilidade cross-site scripting (CVE-2011-0740)
mcabber acidente Fix, segfault, corrupção de linha de comando e vazamentos FD
mediawiki Corrigir uma vulnerabilidade de injeção de CSS
mediawiki-extensions PHP 5.3 correções de compatibilidade para o confirmedit plugin
náutilo Corrigir falha no nautilus_file_peek_display_name ()
network-manager Só comentar correspondências exatas em / etc / network / interfaces, chaves normalizar analisador ifupdown; lidar corretamente com a remoção do dispositivo
ocrodjvu Fix geração de cabeça para baixo dos dados hocr
ocsigen Adicionar dependências que estão faltando em {lib, xhtml ocsigen LWT-ssl-}-dev-ocaml
pdftk Suporte alertando para ambos e senhas de usuários do proprietário; permitir nomes de começar com estranhos , mesmo ou fim
pulseaudio Fix pacmd pendurado na enquete () quando lendo a partir de stdin muito cedo
python-defaults Utilize caminho completo para intérpretes em Python para facilitar pycompile lenny para espremer atualizações
samba Faltando entrada sanisiting
sobby Certifique-se de arquivos de sessão são graváveis ​​pelo usuário sobby
sudo Resolver questões de interoperabilidade entre-H e sua casa no env_keep
sun-java6 Várias correções de segurança
ttf-libertação bandeira corretamente Libertação Mono como monoespaçada
tzdata Nova versão upstream; atualização do horário de verão chileno
usb modeswitch-dados Fix modeswitching linhas para aparelhos da Huawei, adicionar suporte para mais dispositivos
por Aperte a versão de Marcos é Coq como um provador compatíveis
xorg-server Corrigir falhas com controles remotos MCE; correção de rotação [nvidia]; apoio de gota para XF86Config-4
xserver-xorg-video-intel Fix dereference ponteiro nulo e as questões relacionadas com a SDL
Instalador Debian

O Instalador Debian foi atualizado nesta versão aponte para corrigir os seguintes problemas (entre outros):

a ativação de espremer-updates em instalações sem um espelho de rede causou uma falha a ser mostrado,
os layouts de teclado suíço-alemão, búlgaro e suecas foram inutilizável durante a instalação e
esperar mais tempo para discos para inicializar.
Além disso, agora suporta a instalação no seguinte hardware:

QNAP TS-112, TS-212 e TS-412 (novo)
QNAP TS-419P + (novo)
Buffalo LinkStation LiveV3 (novo)
Buffalo Mini Linkstation (novo)
IBook G4 (restaurado)
Cobalto (restaurado)
SPARC hardware (restaurado funcionalidade usando mídia de CD-ROM de instalação e placas gráficas atyfb)
A imagem do kernel utilizado pelo instalador foi atualizado para incorporar uma série de correções importantes e relacionados com a segurança em conjunto com o suporte de hardware adicional.

Atualizações de Segurança

Esta revisão adiciona as seguintes atualizações de segurança para a versão estável. A Equipe de Segurança já lançou um alerta para cada uma dessas atualizações:

Assessoria ID Pacote Correção (s)
DSA-2157 postgresql-8.4 buffer overflow
DSA-2158 cgiirc Cross-site scripting falha
DSA-2160 tomcat6 Várias questões
DSA-2162 openssl acesso à memória inválido
DSA-2163 python-django Cross-site scripting e melhorias de proteção CSRF
DSA-2163 dajaxice correção de compatibilidade para melhorias proteção CSRF
DSA-2164 sombra Faltando sanitização de entrada
DSA-2166 cromo navegador Várias vulnerabilidades
DSA-2167 phpmyadmin injeção de SQL
DSA-2168 openafs Várias vulnerabilidades
DSA-2169 telepatia gabble Falta de validação de entrada
DSA-2170 carteiro Várias vulnerabilidades
DSA-2171 asterisco buffer overflow
DSA-2173 pam-pgsql buffer overflow
DSA-2174 avahi A negação de serviço
DSA-2175 samba Faltando entrada sanisiting
DSA-2177 pywebdav injeção de SQL
DSA-2178 pango1.0 Cancelamento do ponteiro NULL
DSA-2180 iceape Várias vulnerabilidades
DSA-2182 logwatch Execução remota de código
DSA-2184 isc-dhcp A negação de serviço
DSA-2185 proftpd-dfsg Integer overflow
DSA-2186 iceweasel Várias vulnerabilidades
DSA-2187 icedove Várias vulnerabilidades
DSA-2189 cromo navegador Várias vulnerabilidades
DSA-2190 wordpress Várias vulnerabilidades
DSA-2192 cromo navegador Várias vulnerabilidades
URLs

A lista completa dos pacotes que foram alterados com esta revisão:

http://ftp.debian.org/debian/dists/squeeze/ChangeLog
A atual distribuição estável:

http://ftp.debian.org/debian/dists/stable/
Atualizações propostas para a distribuição estável:

http://ftp.debian.org/debian/dists/proposed-updates
Informações sobre a distribuição estável (notas de lançamento, erratas, etc):

http://www.debian.org/releases/stable
Anúncios de segurança e informações:

http://security.debian.org/

Fonte: http://debian.org

Deixe uma resposta